Marketplace Simulations: access issues
Incident Report for Marketplace® Simulations
Postmortem

The incident impact: Marketplace Simulations web services were inaccessible on March 29, 2023 from 13:39 until 14:38 EDT.

Actions taken to mitigate or resolve the incident: The Marketplace Simulations monitoring service notified the on-call sysadmin about the issue with web services. After troubleshooting, it was determined that there were access/network issues causing the trouble.  A call was placed to the service provider where Marketplace Simulations servers are hosted, to investigate further, and resolve the issue.

The incident's root cause: The root cause was identified as a firewall policy that was inadvertently altered during troubleshooting work, resulting in removal of outbound access for Marketplace Simulations servers via DNS, NTP, HTTP/HTTPS, and SMTP.

Follow-up actions taken to prevent the incident from happening again: Through follow-up conversations with the service provider and our account representatives, the engineer and other staff have been instructed that no work that will potentially impact Marketplace Simulations is to take place outside of an approved maintenance window.

Posted Apr 19, 2023 - 09:06 EDT

Resolved
All services are still stable and the issue is resolved. We will continue to monitor services, and will post a full postmortem of the incident in the coming days.
Posted Mar 29, 2023 - 15:03 EDT
Monitoring
A fix has been implemented, and we are monitoring to ensure there are no further troubles.
Posted Mar 29, 2023 - 14:42 EDT
Update
We have a fix in place for web services access; users should be able to access and login to their accounts at https://game.ilsworld.com at this time. We are still working on a final fix that will also restore game processing.
Posted Mar 29, 2023 - 14:34 EDT
Update
The issues appears to be a DNS issue within the primary datacenter. We are working with the provider to get this issue resolved.
Posted Mar 29, 2023 - 14:22 EDT
Identified
The issue has been identified as a networking issue at our primary datacenter. We are working on restoring access as quickly as possible.
Posted Mar 29, 2023 - 14:01 EDT
Investigating
We are aware of issues accessing our gameplay site, https://game.ilsworld.com. We are currently investigating the issue.
Posted Mar 29, 2023 - 13:50 EDT
This incident affected: Marketplace® Simulations Web Services and Marketplace® Simulations Game Processing.