Marketplace Game Processing
Incident Report for Marketplace® Simulations
Resolved
We have resolved the situation, all games should now be processing as scheduled, and any games that were delayed have been processed.
Posted Oct 21, 2020 - 10:51 EDT
Investigating
We are currently having trouble processing games. We are investigating the issue, and hope for the downtime to be minimal. Access to games for students and instructors is NOT impacted, but games will not be able to process while this situation is being resolved.
Posted Oct 21, 2020 - 10:17 EDT
This incident affected: Marketplace® Simulations Game Processing.