Marketplace Simulations: Support contact via email not working.
Incident Report for Marketplace® Simulations
Resolved
Email functionality has been restored at this time. Any emails sent during the downtime were received and queued, and will be responded to immediately.
Posted Sep 15, 2022 - 12:03 EDT
Investigating
We are currently unable to receive emails, including those sent to our support department. If you have a pressing support issue, please call us at +1(865) 522-1946, and our support personnel are ready to assist you right away.
Posted Sep 15, 2022 - 11:22 EDT
This incident affected: Marketplace® Simulations Support Site.